iCompass - Connectivity issues in the US region

Incident Report for Diligent

Resolved

Confirmed connectivity has now resolved
Posted Jan 23, 2023 - 16:54 UTC

Investigating

The SRE team are investigating reports of users unable to access iCompass sites in the US region
Posted Jan 23, 2023 - 16:18 UTC
This incident affected: Mission Driven - iCompass (iCompass (North America - US)).