Diligent Contact Center - Phone Support Unavailable
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 20:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 20:23 UTC
Identified
Customers are currently not able to reach support via the phone. A workaround is available via emailing our support teams at support@diligent.com
Posted Jan 22, 2025 - 18:48 UTC
Investigating
Customers are currently not able to reach support via the phone. A workaround is available via emailing our support teams at support@diligent.com
Posted Jan 22, 2025 - 18:48 UTC
This incident affected: Diligent Contact Center (Diligent Contact Center (North America - US)).