BoardEffect access issue - Globally impacted
Incident Report for Diligent
Postmortem

On March 24, 2023 new release deployment was performed on BoardEffect servers, on all regions. After the new release deployment, during post release validation phase, login problems to BoardEffect were detected. SRE and Development Teams decided to roll back to previous release to solve the problem. After release rollback, the login problems disappeared, problem was solved.

Posted Mar 30, 2023 - 07:10 UTC

Update
This incident has been resolved.
Posted Mar 24, 2023 - 11:42 UTC
Resolved
Issue has been resolved by rolling back the previous release. Login for all regions are now working fine. Thanks for your patience.
Posted Mar 24, 2023 - 11:42 UTC
Update
Issue has been resolved
Posted Mar 24, 2023 - 11:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2023 - 11:36 UTC
Update
Login to all regions are now available, except US. We are working on the solution with priority.
Posted Mar 24, 2023 - 11:27 UTC
Update
All regions are now available, except US. We are working on the solution with priority.
Posted Mar 24, 2023 - 11:26 UTC
Identified
The issue was caused by a broken release and currently planned for rolling back, and ETA for resolution will be 60-90 minutes. Thanks for your patience.
Posted Mar 24, 2023 - 11:12 UTC
Update
SRE team investigating on the issue in Priority
Posted Mar 24, 2023 - 11:07 UTC
Investigating
BoardEffect users are not able to login and globally impacted
Posted Mar 24, 2023 - 11:06 UTC
This incident affected: Mission Driven - Boardeffect (Boardeffect (North America - Canada), Boardeffect (North America - US), Boardeffect (Europe - Germany), Boardeffect (Europe - UK), Boardeffect (Asia Pacific - Australia), Boardeffect (US Federal)).