Boards - Users facing issues in uploading DocuSign.
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 16:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2024 - 16:20 UTC
Investigating
Users experiencing issues with uploading Docusign after submitting and failing
Posted Mar 29, 2024 - 16:18 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - US)).