BoardDocs - Some users from US region encountering issues in replacing with random letters and characters in agenda content.
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 15:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2024 - 15:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2024 - 14:39 UTC
Investigating
Agenda content disappears and is replaced with random letters and characters
Posted Jul 15, 2024 - 14:06 UTC
This incident affected: Mission Driven - BoardDocs (BoardDocs (North America - US)).