Entities - EU Users Experience Performance Issues While Logging In
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 11:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2024 - 11:48 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 11:48 UTC
Investigating
EU users are experiencing performance issues while logging in. Once logged in, the product works as expected. Our teams are prioritizing the fix.
Posted Sep 05, 2024 - 11:24 UTC
This incident affected: Governance Operations - Entities (Entities (Europe - UK)).