Boards mobile app login authentication issue
Incident Report for Diligent
Postmortem

Systems Impacted: Boards mobile applications (IOS, Windows Store App, Android) could not complete the login process during this incident. During this incident, logins for the Boards Web user and OneClick users were not affected.

What happened: On January 28th, 2023, Diligent Boards mobile applications users experienced a bug that prevented successful login. Our engineering team traced the root cause back to a backend application which manages password policies for client sites. While this login issue only manifested on mobile applications; we chose to roll back the password policy application to the earlier version and restore service to mobile application users.

Technical details: This incident was caused by a bug in the password policy application, which led the application to think that it was unlicensed. The Diligent development team classified this as a bug and are working on a fix. We think that the license check error was caused by how our application interfaced with the newer version of the password policy manager.

During this incident, a user would not have been allowed to change their password.

Corrective and preventing steps: Diligent applications are designed with high availability and redundancy in mind. We treat every incident as an opportunity for lessons learn to further improve our systems and processes. The following improvements will be implemented:

  1. Improve regression testing on mobile application.
  2. Improve error logging on mobile applications, to clarify and present login errors to the end user.
  3. Enhance monitoring and alerting for password policy manager license errors
Posted Feb 07, 2023 - 10:10 UTC

Resolved
This incident has been resolved.
Posted Jan 29, 2023 - 12:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2023 - 12:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 29, 2023 - 07:00 UTC
Update
Users are not able to login from ios, mac and windows app. Web login an oneclick work fine. Issue is being investigated. Thank you for your patience
Posted Jan 29, 2023 - 05:29 UTC
Investigating
service is degraded
Posted Jan 29, 2023 - 05:22 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - Canada)).