BoardDocs - Some users are experiencing latency and may be unable to access the application
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 20:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2024 - 19:27 UTC
Investigating
The application may be unavailable to users in the US and Canada
Posted Jun 05, 2024 - 18:32 UTC
This incident affected: Mission Driven - BoardDocs (BoardDocs (North America - US)).