Boards - Customers may experience an issue when trying to export a book from the website in US region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Sep 23, 2023 - 14:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2023 - 14:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 23, 2023 - 14:55 UTC

Investigating

Customers may experience an issue when trying to export a book from the website in US region.
Posted Sep 23, 2023 - 14:43 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - US)).