Boards - Admins are not able to upload documents into Boards
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 17:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2024 - 17:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2024 - 15:27 UTC
Investigating
When an Admin uploads a document, the upload doesn't complete and it continues processing.
Posted Apr 19, 2024 - 14:59 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - US), Boards (Europe - Germany), Boards (Europe - UK), Boards (Asia Pacific - Australia)).