Third Party Manager - US region users might experience some slowness
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 12:19 UTC
Monitoring
issue is fixed and Currently monitoring on the issue
Posted Mar 20, 2023 - 11:14 UTC
Update
SRE team currently investigating on the Third party manager sites experiencing slowness.
Posted Mar 20, 2023 - 11:09 UTC
Update
Third Party Manager sites are facing slowness for users in US regions
Posted Mar 20, 2023 - 11:08 UTC
Investigating
3PM on US is taking too long to load. Affecting multiple clients.
Posted Mar 20, 2023 - 11:07 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).