Third Party Manager's dashboard loading slow

Incident Report for Diligent

Update

This incident has been resolved.
Posted Mar 21, 2023 - 17:16 UTC

Resolved

Issue has been resolved, we will continue to monitor.
Posted Mar 21, 2023 - 17:16 UTC

Monitoring

Issue appears to be much better now, we will continue to monitor from our side.
Posted Mar 21, 2023 - 16:03 UTC

Update

Investigation continues for slowness in dashboard loading
Posted Mar 21, 2023 - 09:06 UTC

Update

SRE and Dev teams are still checking the slowness issue with priority
Posted Mar 21, 2023 - 08:45 UTC

Investigating

Third Party Manager's dashboard in the US is taking too long to load.
Posted Mar 21, 2023 - 08:14 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).