iCompass - Sites May Not Be Accessable for Users

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Sep 20, 2023 - 21:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2023 - 19:55 UTC

Investigating

Canadian users may experience issues when loading iCompass Sites.
Posted Sep 20, 2023 - 19:46 UTC
This incident affected: Mission Driven - iCompass (iCompass (North America - Canada)).