iCompass sites in Canada region are down.
Incident Report for Diligent
Postmortem

On the 22nd of March 2023, Two iCompass sites in Canada region were not loading because of a cert issue. This is due to a security restriction on which certificate provider could be used to generate iCompass certs. The Ops team made a change to allow multiple certificate providers which solved the issue and should prevent from a similar issues in the future.

Posted Mar 30, 2023 - 07:15 UTC

Resolved
impacted sites are up and running.
Posted Mar 22, 2023 - 17:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2023 - 17:03 UTC
Investigating
Few iCompass sites in Canada regions are down. Issue is with our cloud provider, we are working on the fix with priority. Sorry for the inconvenience caused.
Posted Mar 22, 2023 - 16:21 UTC
This incident affected: Mission Driven - iCompass (iCompass (North America - Canada)).