Boards - Customers may experience issues when trying to reset their password

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Sep 23, 2023 - 12:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2023 - 12:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 23, 2023 - 12:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 23, 2023 - 12:20 UTC

Investigating

Customers may experience issues when trying to reset their password and receiving an error message saying 'new password invalid.' The team is working on a fix with priority. Sorry for the inconvenience.
Posted Sep 23, 2023 - 12:11 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - Canada), Boards (North America - US), Boards (Europe - Germany), Boards (Europe - UK), Boards (Asia Pacific - Australia)).