iCompass - Some Users May Experience Slow Performance in Loading sites in Canada Region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Nov 17, 2023 - 22:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2023 - 16:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 17, 2023 - 16:08 UTC

Investigating

CA customers facing slow performance in loading sites.
Posted Nov 17, 2023 - 15:41 UTC
This incident affected: Mission Driven - iCompass (iCompass (North America - Canada)).