Third-Party Manager - Users from EU region encountering issues in forms
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 09:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2024 - 08:57 UTC
Investigating
We are currently investigating this issue.
Posted Nov 08, 2024 - 08:02 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (Europe - Germany)).