BoardsWeb US Intermittent error on login
Incident Report for Diligent
Resolved
We're sorry for the frustration this issue has caused and appreciate your patience as we worked to resolve it.
Posted Mar 13, 2024 - 01:32 UTC
Update
The root cause has been identified an a workaround has been applied.
Posted Mar 13, 2024 - 01:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2024 - 01:10 UTC
Investigating
We are currently investigating this issue.
Posted Mar 13, 2024 - 01:01 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - US)).