BoardDocs - Users have reported service slowness or unavailable
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 20:05 UTC
Investigating
We are currently investigating this issue.
Posted Mar 11, 2024 - 19:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2024 - 19:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2024 - 19:01 UTC
Investigating
Clients have reported that the BoardDocs service is slow to load pages. Other clients have also reported receiving an error and some have trouble loading the site.
Posted Mar 11, 2024 - 18:35 UTC
This incident affected: Mission Driven - BoardDocs (BoardDocs (North America - US)).