Boarddocs issues with viewing documents prior to 2023.

Incident Report for Diligent

Update

Issue is fixed and users have confirmed
Posted May 31, 2023 - 12:21 UTC

Resolved

This incident has been resolved.
Posted May 31, 2023 - 12:21 UTC

Monitoring

Issue has been identified and fixed.
Posted May 31, 2023 - 12:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 31, 2023 - 07:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 31, 2023 - 06:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 31, 2023 - 03:56 UTC

Investigating

We are seeing issues with customers being able to retrieve documents prior to 2023 and are working on a fix for this.
Posted May 30, 2023 - 22:33 UTC
This incident affected: Mission Driven - BoardDocs (BoardDocs (North America - US)).