Boards - Some Clients are unable to Login to Boards in the Canada region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Jul 26, 2025 - 06:38 UTC

Monitoring

Some Clients are unable to login to Boards through the web browser or via iOS in the Canada region
Posted Jul 26, 2025 - 06:36 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - Canada)).