Boards - Users facing performance issues in EU region
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 11:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2024 - 11:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2024 - 11:10 UTC
Investigating
Users are facing performance issues in the EU region. Books are opening slowly, and we are working on the solution with priority. Sorry for the inconvenience caused.
Posted Sep 02, 2024 - 10:56 UTC
This incident affected: Board & Leadership - Boards (Boards (Europe - Germany)).