Third Party Manager - users may receive duplicate email notifications

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Jul 22, 2024 - 10:36 UTC

Investigating

We are currently investigating this issue.
Posted Jul 22, 2024 - 07:52 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).