Boards - Users Unable to Sync Books
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 22:52 UTC
Investigating
Users have reported "An Unexpected Error Occurred" when signing in on their iPads and attempting to sync their books.
Posted Nov 28, 2024 - 18:56 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - Canada)).