Questionnaires connectivity issue - Globally impacted

Incident Report for Diligent

Resolved

Team continues to monitoring on the situation and its impact hence agreed to park the incident.
Posted Mar 09, 2023 - 17:30 UTC

Update

Diligent has identified a global issue with Questionnaires disconnecting users and requiring reauthentication
Posted Mar 09, 2023 - 14:56 UTC

Investigating

We are currently investigating and will have an update and eta soon.
Posted Mar 09, 2023 - 14:55 UTC
This incident affected: Board & Leadership - Boards (Boards (North America - US)).