Secure File Sharing - Customer Login Disruption in US Regions
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Sep 28, 2024 - 21:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2024 - 21:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2024 - 21:31 UTC
Investigating
Our service is experiencing an interruption that is preventing customer login in US regions.
Posted Sep 28, 2024 - 21:17 UTC
This incident affected: Board & Leadership - Secure File Sharing (Secure File Sharing (North America - US)).