Diligent Contact Center - Users are unable to contact the Support Team through the UK phone line

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 09:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2025 - 09:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2025 - 09:40 UTC

Investigating

Users are currently unable to reach the Support Team when calling from a mobile phone into the UK support number (+44-800-234-6580) Landline calls are working properly. We are actively investigating the issue. In the meantime, you can reach us through our global support number (+1-973-939-9381) or via email (support@diligent.com).
Posted Apr 28, 2025 - 13:00 UTC
This incident affected: Tools - Contact Center (Contact Center (North America - US)).