Third-Party Manager - Users From EU Region Encountering access and latency issue

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 14:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 13:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2025 - 13:02 UTC

Investigating

Users in the EU region are experiencing intermittent connectivity issues when attempting to access the site.
Posted Mar 06, 2025 - 12:42 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (Europe - Germany)).