3 Pm users might experience some slowness when loading the dashboards page. All functions work as expected.
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Mar 01, 2023 - 13:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2023 - 13:07 UTC
Investigating
We are currently investigating and will have an update and eta soon.
Posted Mar 01, 2023 - 12:34 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (Europe - Germany)).