Boards - Service distruption in the EU region

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 10:25 UTC

Monitoring

Users are unable to reach the site in the EU region. Our team is actively investigating the issue with high priority. We apologize for the inconvenience and appreciate your patience as we work to resolve it.
Posted Jun 25, 2025 - 10:23 UTC
This incident affected: Board & Leadership - Boards (Boards (Europe - Germany)).