Get webhook notifications whenever Diligent Customer Facing creates an incident, updates an incident, resolves an incident or changes a component status.
A fix has been implemented and we are monitoring the results.
Posted May 24, 2026 - 13:09 UTC
Update
Boards, BoardEffect, and Entities are currently stable, and all services have recovered except **BoardDocs**, which continues to experience intermittent performance issues.
Our teams are actively working to resolve the remaining impact and will provide additional updates as progress is made.
Posted May 24, 2026 - 11:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2026 - 08:47 UTC
Investigating
Users are intermittently experiencing service degradation in the US region. We are currently investigating. Thank you for your understanding and patience.
Posted May 24, 2026 - 08:14 UTC
This incident affected: Boards & Governance – BoardDocs (BoardDocs (North America - US)), Boards & Governance - Boards (Boards (North America - US)), Boards & Governance – BoardEffect (BoardEffect (North America - US)), and Compliance - Entities (Entities (North America - US)).