3rd Party manager's user might experience some slowness using the application.
Incident Report for Diligent
Update
This incident has been resolved.
Posted Feb 28, 2023 - 21:55 UTC
Resolved
The issue is resolved, please let support know if there are further issues.
Posted Feb 28, 2023 - 21:55 UTC
Update
We have identified issues with the backend provider and are working with them to resolve.
Posted Feb 28, 2023 - 19:31 UTC
Update
We are continuing to investigate the issue. The application remains functional but slow on initial visit.
Posted Feb 28, 2023 - 18:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 28, 2023 - 17:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 28, 2023 - 16:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 28, 2023 - 16:02 UTC
Update
We are continuing to investigate this issue.
Posted Feb 28, 2023 - 15:40 UTC
Update
3rd Party manager's user might experience some slowness using the application. All concerned teams are checking with priority. Sorry for the inconvenience, thanks for your patience.
Posted Feb 28, 2023 - 15:37 UTC
Investigating
We are currently investigating and will have an update and eta soon.
Posted Feb 28, 2023 - 15:34 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US)).