Secure File Sharing - Some Users in the US are unable to access SFS
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted May 29, 2024 - 19:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 29, 2024 - 19:28 UTC
Investigating
Users may be unable to access the service in the United States
Posted May 29, 2024 - 18:49 UTC
This incident affected: Board & Leadership - Secure File Sharing (Secure File Sharing (North America - Canada), Secure File Sharing (North America - US)).