Get webhook notifications whenever Diligent Customer Facing creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2025 - 06:00 UTC
Scheduled
Impact: Please be advised that we will be performing routine maintenance on our systems. As a result, BoardEffect may become briefly unavailable during this time window. We apologize for any inconvenience this may cause.
What do you need to do?: Plan to perform items requiring BoardEffect in the impacted regions outside of the scheduled maintenance window timeline.
Contact: For any questions or if you experience a disruption other than above, please contact BoardEffect Support: support@boardeffect.com
Posted Jul 24, 2025 - 15:40 UTC
This scheduled maintenance affected: Boards & Governance – BoardEffect (BoardEffect (North America - US)).