Third-Party Manager - some users are facing issues in submitting the Form 2.0

Incident Report for Diligent

Resolved

This incident has been resolved.
Posted Jun 06, 2024 - 16:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2024 - 09:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 05, 2024 - 08:52 UTC

Investigating

Users from US and EU regions encountering syncing issue while submitting the Form 2.0
Posted Jun 04, 2024 - 09:58 UTC
This incident affected: Compliance - Third-Party Manager (Third-Party Manager (North America - US), Third-Party Manager (Europe - Germany)).