Risk manager - The application is inaccessible for some users in North America
Incident Report for Diligent
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 19:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2024 - 19:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2024 - 18:25 UTC
Investigating
Some users in North America are unable to access the application
Posted Jun 03, 2024 - 17:26 UTC
This incident affected: HighBond - Risk Manager (Risk Manager (North America - US)).